Don't abbreviate your variables
Something I see a lot in programing is abbreviations of already short words. calculation
becomes calc
, result
becomes res
, or worst case abbreviated all the way to a single letter c
or r
.
I've always found that except for the case of iterators (like i
) there's no need to abbreviate the name of variables. Using the full word makes it a lot easier to understand code when you come back to it six weeks later. If your code becomes unreadable because of that extra length in the variable name then that points to bigger problems in the code, and that it should be refactored out into a separate function.
Long gone are the days of writing code on punch cards, there's no need for brevity in variable names, only the need for clarity.
